Delay in activating Hotjar trials
Incident Report for Hotjar
Resolved
This incident is now resolved. Thanks for bearing with us!
Posted Mar 04, 2024 - 10:49 UTC
Investigating
We're investigating an issue that caused a delay in offering new trials between 02:00 - 11:00 UTC.
Posted Mar 04, 2024 - 10:28 UTC