Some users run into "Something went wrong. please try again later." error
Incident Report for Hotjar
Resolved
This incident has been resolved. Thanks for bearing with us!
Posted Mar 11, 2024 - 21:46 UTC
Identified
We've identified the root cause of this incident, and a fix is being developed.

We'll post an update to let you know once we move on to monitoring the fix. Thanks again for bearing with us!
Posted Mar 11, 2024 - 20:19 UTC
Investigating
We're investigating an issue in Insights where some user accounts run into a "Something went wrong. please try again later." error.

Our engineers are working to fix the issue ASAP, we will post updates to status.hotjar.com.

Thanks for bearing with us while we look into this!
Posted Mar 11, 2024 - 20:09 UTC
This incident affected: Application (insights.hotjar.com).