Some users of Microsoft email not receiving registration emails
Incident Report for Hotjar
Resolved
This incident is now resolved. Thanks for bearing with us.
Posted Feb 28, 2024 - 13:33 UTC
Identified
We've identified the issue and are working on a fix.

For some context, some Microsoft mail servers are discarding emails after accepting their delivery.
Posted Feb 19, 2024 - 16:52 UTC
Investigating
We're investigating an issue where some users of Microsoft email (Outlook, etc.) are not receiving registration emails from us.

Our engineers are working to fix the issue ASAP and will post updates to status.hotjar.com.

Thanks for bearing with us!
Posted Feb 14, 2024 - 14:11 UTC